在 cygwin 上安装最新版本的软件包?

我打算在 Cygwin 上运行 Emacs 23,但是当我安装 cygwin 时,只需设置 emacs21。 究竟如何升级现有的 Cygwin 安装以使用 Emacs23? 我知道 emacs 23 是可用的,因为它在此链接中注明。 http://cygwin.com/packages/emacs/

2
2022-06-07 14:42:34
资源 分享
答案: 1

当您处于 Cygwin 安装程序的“选择包”步骤中时:

  1. 单击 emacs paddle 中 New 列中的值(它将与安装选项一起循环)
  2. 选择 emacs 的最新版本(您可能还需要检查“Bin”列中的包)

我发现的一件事是,一旦设置了 emacs 23,Cygwin 就不会为您提供卸载它的选项。 我必须安装 emacs 21,然后它允许我删除 emacs。

5
2022-06-07 15:14:16
资源