apt - get construct - dep troubles

This usually takes place to me. I most likely to install a program and also it claims I am missing out on particular dependences. After that I run apt - get construct - dep and also get a mistake message like the adhering to :

sudo apt-get build-dep gnome-shell
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have unmet dependencies:
libgjs-dev: Depends: xulrunner-dev (< 1.9.2.4~) but 1.9.2.10+build1+nobinonly-0ubuntu0.10.04.1 is to be installed
librsvg2-dev: Depends: librsvg2-2 (= 2.26.2-0ubuntu1) but 2.26.3-0ubuntu1 is to be installed
E: Build-dependencies for gnome-shell could not be satisfied.

What needs to I do to repair this trouble when I assumed this was specifically the sort of trouble construct - dep was made to deal with. Many thanks.

0
2019-12-02 02:47:39
Source Share
Answers: 1

apt-get build-dep is planned to be made use of by programmers to install the construct dependences of a plans ; i.e. the plans that are called for to compile the plan is resource.

Pertaining to the unmet dependences concern, based upon the variation numbers that you have actually uploaded, it resembles you either have actually obsoleted plan details, which can be dealt with by running sudo apt-get update, or you do not have the lucid - updates or lucid - protection databases made it possible for.

See https://help.ubuntu.com/community/Repositories/Ubuntu for aid making it possible for added databases in Ubuntu.

0
2019-12-03 04:07:09
Source