Permission troubles with internet server on Ubuntu

I have a digital host set up on my Ubuntu web server :

<VirtualHost *:80>
     ServerAdmin [email protected]
     ServerName dailysongfix.com
     ServerAlias www.dailysongfix.com

     DirectoryIndex index.php index.html
     DocumentRoot /var/www/dailysongfix/public

     # Custom log file locations
     LogLevel warn

     ErrorLog /var/log/apache2/dailysongfix/error_log
     CustomLog /var/log/apache2/dailysongfix/access_log combined
</VirtualHost>

If I most likely to http : dailysongfix. com I get a restricted mistake. This is possibly a concern with my directory site permissions ...so I visited/ var/www

Here are my permissions :

ls -al /var
drwxr-xr-x  3 root root  4096 May 26 22:47 www

ls -al /var/www/
drwxr-xr-x  3 root root     4096 May 26 22:47 .
drwxr-xr-x 14 root root     4096 May 26 22:46 ..
drwxr-xr-x  3 root www-data 4096 May 26 22:53 dailysongfix

ls -al /var/www/dailysongfix/
drwxr-xr-x 3 root www-data 4096 May 26 22:53 .
drwxr-xr-x 3 root root     4096 May 26 22:47 ..
drwxr-sr-x 2 root www-data 4096 May 26 22:59 public

I additionally have this in my httpd.conf

User www-data
Group www-data

Does any person recognize just how to repair this?

Many thanks!

0
2019-12-02 02:54:14
Source Share
Answers: 2

Looks like I required to transform the Directory permissions :

<Directory "/var/www/dailysongfix/public">
         Options Indexes FollowSymLinks
         AllowOverride None
         Order allow,deny
         Allow from all
     </Directory>
0
2019-12-03 04:26:52
Source

You additionally could intend to "chgrp" from "root" to "www - data" to ensure that any kind of documents upload manuscripts situated in the general public directory site have the ability to effectively conserve documents to that directory site.

There need to be no factor for "root" to be the proprietor team for "public" that I can see.

0
2019-12-03 00:47:34
Source