Apache alias not functioning appropriately

I have actually included these lines in my 000 - default digital host documents :

Alias /antoniocs/project "/home/antoniocs/www/project"
<Directory "/home/antoniocs/www/project">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
</Directory>

/ home/antoniocs/www/ task Contains a drupal internet site

If I most likely to :

localhost/antoniocs/project

This exercises penalty. I see every little thing flawlessly. Yet when I attempt to click a link that takes me, as an example, to :

localhost/antoniocs/project/ group

I get this mistake :

Not Found

The asked for URL/ home/antoniocs/www/ project/index. php was not located on this server.

Is this not handling the.htaccess that remains in the task folder? What am I doing incorrect???

NOTE : I additionally locate it weird that it is offering me a documents course and also not a link course

Running on Apache 2.2.16 (with mod revise) Ubuntu 10.10 php 5.3.3 - 1ubuntu9.1

EXTRA NOTE : For those that do not recognize drupals htaccess, it reroutes every little thing to index.php?q = $1

RewriteCond % REQUEST_FILENAME ! - f

RewriteCond % REQUEST_FILENAME ! - d

RewriteCond % REQUEST_URI ! =/ favicon.ico

RewriteRule ^ (. *) $ index.php?q = $1 [L, QSA ]

0
2019-12-02 03:13:59
Source Share
Answers: 3

It seems like a revise is happening in the incorrect area. As an example, the webserver is searching for the URL /home/antoniocs/www/project/index.php as opposed to the neighborhood documents by the very same course. Probably examine the Drupal installment itself? You can examine what the server assumes by considering the ask for redirection making use of something like crinkle :

curl -I http://localhost/antoniocs/project/category

See if code 301 or 302 is returned, which might aid limit the trouble. E.g. :

$ curl -I http://www.outflux.net/blog
HTTP/1.1 301 Moved Permanently
...
Location: http://www.outflux.net/blog/
0
2019-12-03 05:25:08
Source

Alternatively you can additionally enable userdir component of apache. To make sure that you do not need to create an alias to access the codes that stays in your house directory site

sudo a2enmod userdir
cd ~
mkdir public_html
sudo /etc/init.d/apache2 restart

Put your code under this public_html and also you can access it by http://localhost/~username or http://ipaddress/~username (as an example : http://localhost/~aneesh)

You can transform the directory site name (public_html) by editing and enhancing the conf documents /etc/apache2/mods-enabled/userdir.conf

0
2019-12-03 05:23:45
Source

See if anything below can aid : https://drupal.org/node/163915, your trouble might have something to do with the AllowOverride declaration in ;/ etc/apache2/sites - available/default

0
2019-12-03 05:23:33
Source