LaunchDaemon not acknowledged

I've mounted CouchDB using MacPorts. Currently I intend to start it when my Mac boots, so I implemented the guidelines given up the install procedure:

sudo launchctl load -w /Library/LaunchDaemons/org.apache.couchdb.plist
.

Nonetheless this does not appear to function. I've looked inside the LaunchDaemons directory site, and also the plist documents exists (as a symlink) :

lrwxr-xr-x  1 root  wheel   57 18 aug 10:11 org.apache.couchdb.plist -> /opt/local/Library/LaunchDaemons/org.apache.couchdb.plist
.

The materials of the real plist documents appear alright (nonetheless I have no actual expertise of just how it need to look) :

<plist version="1.0">
  <dict>
    <key>Label</key>
    <string>org.apache.couchdb</string>
    <key>EnvironmentVariables</key>
    <dict>
      <key>HOME</key>
      <string>~</string>


    </dict>
    <key>ProgramArguments</key>
    <array>
      <string>/opt/local/bin/couchdb</string>
    </array>
    <key>UserName</key>
    <string>couchdb</string>
    <key>StandardOutPath</key>
    <string>/dev/null</string>
    <key>StandardErrorPath</key>
    <string>/dev/null</string>
    <key>RunAtLoad</key>
    <true/>
    <key>KeepAlive</key>
    <true/>
  </dict>
</plist>
.

When I execute /opt/local/bin/couchdb by hand, the procedure is developed, so no worry there. It simply appears the launch daemon misses this command.

Any kind of ideas on just how to repair this?

0
2019-05-04 18:15:29
Source Share
Answers: 2

I'm not especially accustomed to CouchDB, yet I see a number of possible troubles with your.plist documents : first, the HOME value being set is unusual - - it need to be a details folder course (i.e. any place you placed the couchdb customer's residence folder), not ~. Second, I believe you additionally require to set the PATH setting variable so CouchDB can locate the various other optional programs you've mounted. To make sure that area of the.plist need to look something similar to this:

<key>EnvironmentVariables</key>
<dict>
    <key>HOME</key>
    <string>/usr/local/var/lib/couchdb</string>
    <key>PATH</key>
    <string>/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/local/bin:/opt/local/sbin</string>
</dict>

(Note : the above values are hunches based upon a little googling - - you might require to readjust them to where your CouchDB customer's residence is and/or where your add - on binaries folders are.) To load the changed.plist documents, usage:

sudo launchctl unload /Library/LaunchDaemons/org.apache.couchdb.plist
sudo launchctl load /Library/LaunchDaemons/org.apache.couchdb.plist

If that does not address the trouble, there are a number of areas to seek even more details concerning what's failing : first, have a look at the system log (/ var/log/system. log), either with the Console energy or a command line device ; it'll have any kind of mistakes that launchd faced while attempting to refine the.plist documents or start CouchDB. Second, adhere to Mark's pointer concerning transforming StandardOutPath and also StandardErrorPath to actual documents, and also considering what programs up there. This isn't required if every little thing's set up effectively, yet can be really valuable for figuring out what's incorrect when there's a trouble (and also you can change them back to/ dev/null after the trouble has actually been addressed).

0
2019-05-09 05:20:35
Source

Try the following ( one - line command ):

sudo chown -R couchdb:couchdb /opt/local/var/lib/couchdb/ /opt/local/var/log/couchdb/ /opt/local/etc/couchdb/ /opt/local/var/run/couchdb

Then reboot.

If it does not function, what variation of MacPorts and also CouchDB do you have?

0
2019-05-09 01:43:00
Source