Mounting Grub 2 on a USB flash drive

MultiBootISOs is a device that allow you install Grub on a USB flash drive. I actually like it due to the fact that it allows me boot from ISO documents and also allow me place a number of ISOs on my USB and also pick which one too.

The trouble is, this is a Windows device, and also I do not recognize just how to do it via the command lines. I would certainly additionally such as to recognize just how to install Grub (2) in this manner, Grub Legacy appears to be less complicated ...

EDIT: I'm not requesting for a device (and also most definitely not a Windows device). I need to know the commands that I need to execute to have the very same results. I'm having Ubuntu in my mind now, yet if there is a basic manner in which I can boot any kind of ISO in the USB then that would certainly be much better.

0
2019-05-06 00:26:58
Source Share
Answers: 2

GRUB2 Bootloader Full tutorial is an excellent area to start on multi boot arrangements with GRUB2.
If you know with GRUB, dive right to the 5th or 6th area.

There is additionally a Superuser inquiry on Setting up a multiboot system with GRUB.
There is additionally a Ubuntu MultiOSBoot area web page which recommends you need to adhere to the Legacy GRUB.

The strategy works with flash drives also as lengthy as your equipment can boot from them.
I have actually been working off flash drives for some time now.

0
2019-05-08 14:42:40
Source

You obtained me interested just how this would certainly be done. The Pendrivelinux site had a tutorial I did this from my Mint 9 install as opposed to a real-time cd as the website recommends.

I began with locating the area of my USB drive in an incurable I ran df it returned the area of the tool as

/dev/sdg1   /media/LINUXUSB

afterwards I ran

sudo su

and afterwards to install grub 2

grub-install --no-floppy --force --root-directory=/media/LINUXUSB /dev/sdg1

I needed to make use of - - pressure in addition, the instance on the website did not. After that I did

cd /media/LINUXUSB/boot/grub

The website offered a link to download and install a duplicate of grub.cfg to the/ boot/grub directory site on my USB drive. The link was

wget http://pendrivelinux.com/downloads/grub.cfg

Afterwards I modified grub.cfg to mirror the iso's on my USB drive.

set timeout=10 set default=0

menuentry "Run Fedora" {
    loopback loop /Fedora13.iso
    linux (loop)/isolinux/vmlinuz0 boot=isolinux iso-scan/filename=/Fedora13.iso splash --
    initrd (loop)/isolinux/initrd0.img
}

menuentry "Run Ubuntu" {
    loopback loop /ubuntu-10.04-netbook-i386.iso 
    linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=/ubuntu-10.04-netbook-i386.iso splash --
    initrd (loop)/casper/initrd.lz
}

menuentry "Run Clonezilla" {
    loopback loop /clonezilla.iso
    linux (loop)/live/vmlinuz boot=live iso-scan/filename=/clonezilla.iso splash --
    initrd (loop)/live/initrd.img }

I located that in the various iso's, vmlinuz and also initrd lay in a various directory site. I had the ability to get all 3 to start the boot process ; yet, just Ubuntu to in fact load. If I identify what I require to get the various other 2 to end up loading, I will certainly add that later on. I have actually not attempted any kind of various other iso's simply these 3.

0
2019-05-08 11:18:10
Source