Ubuntu 11.04 Unity / Classic load fails - remains at background without toolbars / windows

IMPORTANT: Ubuntu Classic (without results) functions. I am attempting to get Unity to function.

I have the adhering to trouble with Ubuntu 11.04 (had it with 10.10 also, yet disabling KMS or making use of the fglrx vehicle driver repaired it - can not bear in mind specifically which), today given that the Radeon vehicle driver is far better than it made use of to be, I intend to utilize it (as well as the fglrx efficiency is unsatisfactory).

Ubuntu boots generally till the login screen. After login, it reveals the history, the mouse is revealed and also it simply continues to be there. It does not freeze, yet it does not load anything else. I can relocate the mouse and also can enter into message console (Ctrl+Alt+F1).

It does not work with Ubuntu account (Unity) or on the Ubuntu Classic (GNOME+results) account. I also attempted mounting GNOME3 from their PPA, yet it does not end up filling either (similar to the various other 2).

My equipment: Toshiba Satellite M40 Notebook, ATI Radeon x600 (128MB) video card

I have not had the ability to locate any kind of mistakes in dmesg or various other logs.

Update 1:

Alt+F2 does not function - - absolutely nothing turns up. There is a GNOME panel filled (I see the procedure in the message console) when attempting Ubuntu Classic (with results). Also the Unity panel solution lots when I make use of the Ubuntu account. I think that something does not end up loading (in both Ubuntu and also Classic with results) due to the fact that if I relocate the mouse over to where the toolbar would certainly be I get the functioning mouse.

Things is with fglrx I get a mistake when attempting to load Unity, claiming to make use of Classic as a result of an absence of equipment. Yet with the Radeon vehicle driver, I do not get that mistake, they appear to start filling yet never ever end up - - they simply hang.

It would certainly behave if the Radeon vehicle driver would certainly permit me to make use of effects/unity/GNOME 3 given that Unity appears to run well on an Intel 945m Express incorporated video card note pad. I wish updates to the driver/Unity will certainly repair my trouble.

$ /usr/lib/nux/unity_support_test -p

OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RV380
OpenGL version string: 2.1 Mesa 7.10.2
Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes
Unity supported: yes

The Unity manuscript claims that I need to be running Unity.

I located great deals of pests connected to this (I assume) like Ubuntu bug 777341 and also Ubuntu bug 758482 and also great deals of inquiries connecting to it below in Ask Ubuntu and also on various other websites. I will certainly think that this is a trouble that will certainly be settled in future Ubuntu updates.

Update 2:

Fiddling with Compiz plugins (Gnome Plugin or Unity Plugin) in CCSM does not aid.

The very same goes with uninstalling Compiz/Unity and also re-installing it.

I am beginning to get the sensation that this is not a very easy point to deal with, and also just a vehicle driver (Radeon/r300g/Gallium)/ Compiz/Unity Ubuntu upgrade will certainly repair this.

4
2022-06-07 14:31:07
Source Share
Answers: 4

Change the GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub in:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=1 pci=nomsi"

Run update-grub and also reboot

The pci=nomsi sufficed for me.

4
2022-06-08 01:42:37
Source

It took place to me, you can do this to deal with:

Go to Ubuntu Classic (without results), start CCSM and also enable Gnome Plugin or Unity Plugin.

Appears that Compiz has some trouble to utilize them both, due to the fact that the plugins appear to problem.

0
2022-06-07 16:21:20
Source

the very same point took place to me and also i assume i have your remedy (or at the very least this is what benefit me)

start up in Ubuntu classi * *c and also most likely to * *system - management - synaptic plan supervisor remove anything that concerns compiz (or anything that has compiz in the name)

currently reactivate your computer system and also start up in Ubuntu and also press ctrl alt t and also your terminal need to show up key in this line sudo proper - get install compiz after that press enter afterwards key in this line sudo proper - get install unity press enter after that sudo proper - get upgrade unity

after its done reactivate your computer system and also boot in to ubuntu and also bam every little thing is back

0
2022-06-07 14:56:16
Source

Second Attempt ¢ Go to a command line Ctrl+Alt+F1. ¢ Create this folder:

mkdir  ~/.config/autostart

Create this documents:

nano ~/.config/autostart/gnome.desktop  

Paste this right into it:

#!/usr/bin/env xdg-open

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Icon[en_US]=gnome-panel
Name[en_US]=Gnome
Exec=gnome-panel
Name=Gnome
Icon=gnome-panel

Then

sudo reboot now

First Attempt ¢ I required to place gnome-panel as a command at Startup Applications (Alt+F2 and also pastegnome-session-properties) to deal with something similar to this. Can you examine it?

0
2022-06-07 14:55:15
Source

Related questions