E763 with vim and spell checker

I intend to add germand spell checking to vim. So I set

:set spl=de_de spell

after that there is a discussion, where I can create a directory site called .vim/spell. And afterwards there is an additional inquiry where I can download and install a .spl documents. And also once more for a .sug documents. Yet when I download and install both files I get a mistake

Fehler beim Ausführen von "~/.vim/spell/de.utf-8.spl":
E763: 'Word Characters' unterscheiden sich zwischen Rechtschreibwörterbüchern

But regardless of the mistake I can make use of the spell checking and also also the pointer functions.

Additionally I can not :mksp my very own .spl - documents from myspell, create it would not read the .dic - documents. And also I removed the spelldirectory and also retried it. Absolutely nothing functioned.

5
2022-06-07 14:32:47
Source Share
Answers: 3

Debian wheezy:

sudo apt-get install vim-scripts # Needed for spell downloading script
sudo rm /usr/share/vim/vim73/spell/*.sug /usr/share/vim/vim73/spell/*.spl
sudo vim

currently cause downloading and install in vim:

set spell spelllang=en,de,OR_WHATEVER_LANGUAGE_YOU_WANT

et voilà, you will certainly get flawlessly functioning spell apply for all users.

(If you just desire them for the existing customer, miss the sudo prior to calling vim or, transform the installation directory site to /home/YOUR_USER/.vim/spell.)

3
2022-07-22 14:40:01
Source

I had the very same trouble with a self - assembled Vim 7.3.729 on Windows/x64. As the spell files at http://ftp.vim.org/vim/runtime/spell/de/ have not been upgraded yet, I addressed this in the adhering to way:

  1. download and install the Arch Linux plan stated in skunk is solution from https://www.archlinux.org/packages/extra/any/vim-spell-de/
  2. Extract the spell files from the vim-spell-de-20120506-1-any.pkg.tar.xz documents ( 7Zip can unbox them)
  3. Overwrite the 4 files de.{latin1,utf-8}.{spl.sug} in ~/.vim/spell/
1
2022-07-05 22:42:09
Source

I had a comparable concern (very same errormessage) and also I presume, it resulted from a compatibility - trouble. The spell files I made use of (mounted in.vim/ spell) were from an older installment of vim and also when I upgraded vim, I obtained this mistake. I addressed it by utilizing the vim spell files given by my circulation - - in my instance Arch Linux

sudo pacman -S vim-spell-de
1
2022-06-08 03:42:40
Source