Cannot connect to my Virtual Box Ubuntu system

I have a VirtualBox running an Ubuntu OS. I would certainly such as to accessibility this Ubuntu equipment making use of ssh or telnet. In order to do that I've executed the adhering to actions:

  1. sudo apt-get install telnetd
  2. sudo /etc/init.d/openbsd-inetd restart

Then I attempted to accessibility this system making use of telnet from an additional equipment yet however the link come to be break:

# telnet 10.125.31.176
Trying 10.125.31.176...
telnet: connect to address 10.125.31.176: Connection timed out
telnet: Unable to connect to remote host: Connection timed out

Also I would certainly such as to state that I can conveniently ping this equipment (both means) :

# ping 10.125.31.176
PING 10.125.31.176 (10.125.31.176) 56(84) bytes of data.
64 bytes from 10.125.31.176: icmp_seq=1 ttl=57 time=2.34 ms
64 bytes from 10.125.31.176: icmp_seq=2 ttl=57 time=1.81 ms

EDIT :. I have additionally executed the open ports check and also it appears ok:

$ sudo nmap -p 20-2550 localhost 

Starting Nmap 5.00 ( http://nmap.org ) at 2012-06-11 15:31 IDT
Warning: Hostname localhost resolves to 2 IPs. Using 127.0.0.1.
Interesting ports on localhost (127.0.0.1):
Not shown: 2526 closed ports
PORT    STATE SERVICE
22/tcp  open  ssh
23/tcp  open  telnet
25/tcp  open  smtp
587/tcp open  submission
631/tcp open  ipp

Nmap done: 1 IP address (1 host up) scanned in 1.54 seconds

EDIT2 : ifconfig from the VirtualBox Ubuntu :

eth0      Link encap:Ethernet  HWaddr 08:00:27:0d:43:7d  
          inet addr:10.125.31.176  Bcast:10.125.31.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe0d:437d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9247631 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10147 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3145994247 (3.1 GB)  TX bytes:727714 (727.7 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:30446 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30446 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1280714 (1.2 MB)  TX bytes:1280714 (1.2 MB)

Windows IP Configuration

Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . : xxx.com
    IP Address. . . . . . . . . . . . : 10.125.31.170
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 10.125.31.1

Ethernet adapter VirtualBox Host-Only Network:

    Connection-specific DNS Suffix  . :
    IP Address. . . . . . . . . . . . : 192.168.56.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :

Any suggestions?

5
2022-06-07 14:33:59
Source Share
Answers: 2

I'm rather sure this is trouble with network arrangement on you VirtualBox.

Open VM setups:

  1. Make certain you select Bridged Adapter (I anticipate you have NAT set up which does not permits to course links from outdoors to your VM)

  2. Select readily available network card (I made use of MS Loopback adapter, on your computer it will certainly be various)

More details here and also here

4
2022-06-07 14:58:49
Source

So below remain in one solution a recap of my remarks.

You have 3 remedies relying on your setting:

A. Your Windows host is attached to a network

1 - Use "Bridge networking"

And select the Windows network user interface that is set up under Windows to have network accessibility.

See to it you have no firewall program on Ubuntu: sudo iptables -L needs to offer you no regulations.

2 - Use "NAT" with port - forwarding

Select NAT and also unflod the innovative setups of the NAT user interface in VirtualBox setups. After that you click the Port Forwarding switch and also create a new regulation, you call it "telnet" (or whatever you favor), method needs to be "TCP", leave the areas Host and also Guest IP vacant, yet set the Host and also Guest Port to 23.

Examine the exterior IP address of the VM to accessibility it. This IP address coincides one when it comes to the VirtualBox Host - just network, you can examine the IP in Windows networking facility by clicking the user interface and also presenting its status/details. Or you can sign in VirtualBox choices (not the VM Settings, yet the VirtualBox choices) under network, examine the IP address of the Host - just ethernet adpater (click the Edit switch of this user interface).

See to it you have no firewall program on Ubuntu: sudo iptables -L needs to offer you no regulations.

B. Your Windows host has no network

Use "Host - only" networking. Absolutely nothing else to set up.

The IP address to make use of is the one given up Ubuntu when you run ifconfig.

See to it you have no firewall program on Ubuntu: sudo iptables -L needs to offer you no regulations.

8
2022-06-07 14:53:00
Source