Random freezes followed by loss of WiFi connection with a BCM4313 wireless card

I did a tidy install of Natty Narwhal on my AspireOne D255 Netbook. At once, it appears to function right out of box, yet periodically (specifically quickly after starting up or returning to from rest), mouse arrow would certainly ices up, adhered to by a decrease in WiFi link.

Can any person deal with recommending just how to repair this aggravation?

Simply some history details. My system is not effective adequate to run Unity, so it is under timeless setting presently.

Below is the result from lspci

00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Atheros Communications AR8152 v1.1 Fast Ethernet (rev c1)
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

Here is the passage from dmesg

[ 8127.020293] eth1: no IPv6 routers present
[ 8154.099945] psmouse.c: TouchPad at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
[ 8155.128208] psmouse.c: resync failed, issuing reconnect request
[ 8195.396010] atl1c 0000:01:00.0: atl1c: eth0 NIC Link is Up<100 Mbps Full Duplex>
[ 8195.924818] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 8210.300491] psmouse.c: TouchPad at isa0060/serio1/input0 lost synchronization, throwing 5 bytes away.
[ 8215.851447] atl1c 0000:01:00.0: irq 45 for MSI/MSI-X
[ 8217.129771] atl1c 0000:01:00.0: atl1c: eth0 NIC Link is Up<100 Mbps Full Duplex>
[ 8217.651271] psmouse.c: resync failed, issuing reconnect request
[ 8219.160058] eth0: no IPv6 routers present
2
2022-06-07 14:34:47
Source Share
Answers: 2

Here is a possible solution

sudo gedit /etc/default/grub
// Make sure the following is added
GRUB_CMDLINE_LINUX="i8042.nomux"
// Save the file and exit gedit
sudo update-grub

Only time will certainly inform if mouse panics once more. Simply used this establishing 30 minutes earlier, and also I will certainly await at the very least 72 hrs prior to making remarks

0
2022-06-07 19:23:34
Source

There are a few other encountering troubles with that said chipset in Natty. Have a look at this question for details on just how to address your trouble.

0
2022-06-07 16:22:31
Source