daemon function in /init.d does not run the program in the background in fedora13

I make use of Fedora 13 and also am attempting to create a solution for darkice. I placed the manuscript in the /etc/init.d directory site and also if I make use of the command service darkice start, the darkice is running in the foreground and also the command punctual is not returned.

Just how do I make darkice run in the history?

The following is the passage from the darkice manuscript.

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/local/bin/darkice
NAME=darkice
DESC="Darkice live audio streamer"

test -x $DAEMON || exit 0
CONFIGFILE="/etc/darkice.cfg"

# Source function library.
. /etc/rc.d/init.d/functions


# See how we were called.
case "$1" in
  start)
    # Start daemon.
    echo -n $"Starting darkice streaming daemon: "
    daemon "$DAEMON -c $CONFIGFILE > /dev/null"
    RETVAL=$?
    echo
    [ $RETVAL -eq 0 ] && touch /var/lock/subsys/darkice
    ;;
  stop)
2
2022-06-07 14:35:13
Source Share
Answers: 1

In man darkice there is no details concerning running darkice in history (daemon setting), yet I located site where init script is provided.

Darkice is begun in screen with -d switch that promptly detach screen. Entire command to run it resembles this:

DARKCONFIG="/home/drmoreau/darkice/darkice.cfg"
DARKBIN="darkice"
DARKCMD="$DARKBIN -c $DARKCONFIG"
DARKUSER="PUT YOUR LOCAL USERNAME HERE IN LOWERCASE"
SCREENEXE="screen"
SCREENOPTS="-d -m -S darkice_stream"
su "$DARKUSER" -c "$SCREENEXE"" $SCREENOPTS"" $DARKCMD"
1
2022-06-07 14:56:12
Source