Migrating old Xcode project to version 4.3

Today I relocated to the most up to date variation of Xcode (4.3). I attempted to open an old task and also when I attempt to release the iOS simulator it returns me the adhering to mistake:

Xcode cannot run using the selected device.

No provisioned iOS devices are available with a compatible iOS version. Connect an 
iOS device with a recent enough version of iOS to run your application or choose an iOS 
simulator as the destination.

I additionally attempted to create a new task and also there I have the ability to release the simulator.

Just how can I repair this trouble and also run all my old tasks once more?

Many thanks!

4
2022-06-07 14:37:35
Source Share
Answers: 2

The trouble is that Xcode 4.3 overlooks the schema you had actually picked in older variations, and also instantly establishes it to work on tool for iOS tasks. Given that you do not have a qualified tool affixed to your computer system, you get this mistake. The solution is straightforward. In the toolbar, click the food selection which claims iOS Device and also pick among the simulator alternatives rather.

5
2022-06-07 15:09:02
Source

Check to see to it the SDK for the targeted iOS variation in the old task is still on your equipment. As an example, if you constructed the application versus 4.0 and also have actually given that gotten rid of that SDK (updating Xcode might have done that), I would certainly anticipate Xcode to offer such an message.

1
2022-06-07 15:03:29
Source