Unable to install programmes after upgrade

I updated to 11.04 today. I had some troubles when the system iced up with 2 mins to go ; I was compelled to do a tough reboot, yet the system showed up to function OK. (defined below: https://askubuntu.com/questions/40295/distribution-upgrade-froze-my-system)

As the system had not been tidied up prior to restarting, I ran Computer Janitor, yet needed to stop it when I saw it was removing points I required to maintain (as an example Faenze symbols disappeared). Ever since I have actually been incapable to install anything using proper - get, Synaptic or Software Centre. I can add PPAs, yet trying to install anything returns the list below message:

E: Sub - procedure/ usr/bin/dpkg returned a mistake code (1)

The only means I can install anything is by downloading and install the deborah and also mounting by hand.

Attempting to install with the Software Centre creates a window to open claiming "An unhandled mistake took place). Clicking "details" discloses the following:

Traceback (latest call last): File "/usr/lib/ python2.7/dist - packages/aptdaemon/worker. py", line 961, in imitate trans.unauthenticated = self. _ simulate_helper (trans) File "/usr/lib/ python2.7/dist - packages/aptdaemon/worker. py", line 1085, in >_simulate_helper return depends, self. _ cache.required _ download, bkslsh File "/usr/lib/ python2.7/dist - packages/apt/cache. py", line 226, in required_download pm.get _ archives (fetcher, self. _ checklist, self. _ documents) SystemError: E: I had not been able to situate apply for the rec - applet plan. This could suggest >you demand to by hand repair this plan.

Nonetheless, when I attempt to repost the trouble, an additional window opens up with the title "Problem in aptdaemon" and also

The trouble can not be reported:

You have some out-of-date plan variations mounted. Please upgrade the adhering to >packages and also examine if the trouble still takes place:

python - gobject

EDIT - I attempted Jordy is remedy. When I after that looked for neighborhood or out-of-date plans in Synaptic, one was noted in red and also significant for elimination (rec - applet). When I try to remove it, I get the message:

E: rec - applet: subprocess mounted blog post - elimination manuscript returned mistake exit standing 1

It is as if that was obstructing every little thing else, yet there doesn ;t appear to be a means of eliminating it.

EDIT 2 - I remived the annoying plan adhering to the guidelines below: http://www.khattam.info/solved-subprocess-pre-removal-script-returned-error-exit-status-2-error-2009-08-04.html

I really feel a little bit unclean yet it did job, and also no demand to re-install the OS.

1
2022-06-07 14:39:17
Source Share
Answers: 2

Regarding this especially: E: Sub - procedure/ usr/bin/dpkg returned a mistake code (1)

I located a feasible remedy stated in this message here

  • Try apt-get -f install to compel an install of the files that really did not get filled as a result of the mistake. After that tryapt-get upgrade once more, apt-get -f install to and fro till just the plan that has the mistake is left

It is a blog post based upon Debian yet this additionally stands for Ubuntu.

0
2022-06-07 15:07:47
Source

Probably you have damaged plans, type: sudo dpkg --configure-a

2
2022-06-07 14:55:43
Source