Blank screen after installing nvidia restricted driver

I've installed the current nvidia restricted driver and also restarted my equipment and also currently I get a black or empty screen.

Just how can I repair this?

108
2022-06-07 17:00:09
Source Share
Answers: 8

Maybe Ubuntu IT'S working but using another card output. For me, my nVidia GeForce 7300 has 2 output, a VGA and a DVI. It seems like the default output when you install the drivers is to DVI but I don't have a DVI monitor so I managed to get to Recovery Mode (available in GRUB when you boot) and type this:

nvidia-xconfig --twinview --twinview-orientation="Clone"

Now Reboot.

This command directs the same graphics to both outputs. From there on, you can keep experimenting with this nVidia utility until you get what you want. For more information type:

nvidia-xconfig -A | less

Hope that helps.

5
2022-07-07 22:36:15
Source

I obtained an empty screen too, yet this got on a laptop computer with and also nVidia optimus card 4200m. Optimus does not appear to be sustained well on Ubuntu. I needed to disable optimus from the biographies and afterwards re-install the nividia vehicle driver. Extra below if you intend to read http://developerslog.org/?p=69

0
2022-07-01 17:26:04
Source

Try acpi=off. That addressed my booting right into empty screen concern for Ubuntu 11.10.

0
2022-06-10 17:05:15
Source

Try in /etc/default/grub:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_GFXMODE=1680x1050x32

Replace "1680x1050x32|with your indigenous resolution (to get it run vbeinfo in the grub console when starting).

After that in /etc/grub.d/00_header:

set gfxmode=${GRUB_GFXMODE} <-- FIND THIS LINE
set gfxpayload=keep <-- ADD THIS LINE DIRECTLY BENEATH

Update grub:

sudo upgrade - grub

Might job

0
2022-06-08 01:59:17
Source

Does that thread on Ubuntu Forums aid you?

Basically, it appears that the linux - header plans for several of the bits (especially the PAE bits) are not effectively mounted, and also the nvidia vehicle driver collection falls short calmly when mounting the nvidia plans.

2
2022-06-07 21:19:47
Source

Instead of making use of nvidia - existing you need to actually attempt to make use of an older nvidia vehicle driver as an example the 173. xx. This addressed the trouble for me. Simply start jockey - gtk and also picked the 173. xx vehicle driver. Than reboot your system.

0
2022-06-07 20:50:42
Source

Regarding the subject title: What is the existing limited nvidia vehicle driver variation made use of in Ubuntu natty?

You can locate anything concerning launches, variations, pests, asked for attributes on Launchpad. To recognize what it has to do with you can take their tour.

The inquiry concerning the most up to date variation of the nVidia vehicle driver can be located on “nvidia-current” binary package in Ubuntu Natty i386. So since 2011 - 04 - 20 the most up to date variation is 270.41.06 - 0ubuntu1. Yet that is not always the advised one. The most up to date one for me constantly appears buggy (like 'tearing' etc).

0
2022-06-07 17:56:38
Source
  1. Remove any kind of vehicle drivers that might be creating the concern,

  2. open the incurable and also type (open it from the dashboard, making use of the ubuntu symbol on the left edge)

     sudo apt-get --purge remove nvidia
    

    or

     sudo apt-get --purge remove nvidia-current
    

    (Depending on which one you have actually mounted) or deactivate them from the limited vehicle driver setups.

  3. reboot.

  4. after that on an incurable type this:

     sudo apt-add-repository ppa:ubuntu-x-swat/updates
     sudo apt-get update
     sudo apt-get install nvidia-current nvidia-settings
    
  5. reboot.

10
2022-06-07 17:45:06
Source