Just how do I inscribe mp4 documents with H. 264 (or x264) codec in AVIDemux?

I am attempting to get AVIDemux set up with the X264 codec making use of this tutorial. The following is what drops when I reach the ./configure --enable-mp4-output command

Thomas-Phillipss-MacBook:x264 tomdabomb2u$ sudo ./configure --enable-mp4-output
Password:
Unknown option --enable-mp4-output, ignored
Found no assembler
Minimum version is yasm-0.6.2
If you really want to compile without asm, configure with --disable-asm.

So I attempted it.

Thomas-Phillipss-MacBook:x264 tomdabomb2u$ sudo ./configure --enable-mp4-output --disable-asm
Unknown option --enable-mp4-output, ignored
Warning: gpac is too old, update to 2007-06-21 UTC or later
Platform:   X86_64
System:     MACOSX
asm:        no
avs:        no
lavf:       no
ffms:       no
gpac:       no
pthread:    yes
filters:    crop select_every
debug:      no
gprof:      no
PIC:        no
shared:     no
visualize:  no
bit depth:  8

You can run 'make' or 'make fprofiled' now.

I released make, and afterwards Thomas-Phillipss-MacBook:x264 tomdabomb2u$ ./x264 -v -q 20 -o foreman.mp4 foreman_part_qcif.yuv 176x144. And also as anticipated, the outcomes are:

x264 [error]: not compiled with MP4 output support

So I'm stuck. Any kind of suggestions?

0
2019-05-03 18:12:42
Source Share
Answers: 1

That's a rather old tutorial. Attempt this one (connected from the main Avidemux website).

0
2019-05-08 09:59:18
Source

Related questions