How to speed my also - slow-moving ssh login?

Running ssh [email protected] takes ~ 30s. Below is the circumstance:

  • this is a VM on the neighborhood LAN
  • Windows and also Mac equipments get instantaneous login
  • am making use of Debian and also I could duplicate with an Ubuntu equipment
  • a person making use of Ubuntu claims that logging right into my equipment (neighborhood LAN) is additionally instantaneous
  • making use of hostname IP address takes concerning fifty percent as much time (~ 15s)

[ upgrade ]

Using ssh -vvv [email protected], below is where it waits one of the most:

debug3: authmethod_lookup gssapi-with-mic
debug3: remaining preferred: publickey,keyboard-interactive,password
debug3: authmethod_is_enabled gssapi-with-mic
debug1: Next authentication method: gssapi-with-mic

And after that it waits a little bit below:

debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_1000' not found

debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_1000' not found
0
2019-05-13 03:31:13
Source Share
Answers: 3

Edit your" / etc/ssh/ssh _ config " and also comment out these lines:

GSSAPIAuthentication yes
GSSAPIDelegateCredentials no
0
2019-05-21 07:13:00
Source

I had this trouble and also settled it by switching off Reverse DNS resolution in SSH.

So in sshd_config on the web server adjustment this:

 #UseDNS yes

to this:

UseDNS no
0
2019-05-21 07:02:56
Source

Have you validated your DNS arrangement?

Attempt the setup mdns off in /etc/host.conf.

This disables the mdns resolution and also aided me a whole lot.

EDIT:

It appears gentoo is managing this a bit various. To disable multicast DNS lookups, you need to transform the documents /etc/nsswitch.conf.
There need to be something like:

hosts:          files mdns

Change it to:

hosts:          files dns
0
2019-05-17 16:02:51
Source