Unable to connect to Mobile Broadband : Huawei EC1260 - TATA Photon+

I have a TATA Photon+(Huawei EC1260) mobile broadband tool and also am incapable to develop a link either making use of wvdial or the network supervisor.

Below is my wvdial.conf

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
stupid Mode = 1
Modem Type = Analog Modem
ISDN = 0
Phone = #777
Modem = /dev/ttyUSB0
Username = internet
Password = internet
Baud = 9600

and also below some details from/ var/log/messages

Sep 30 15:45:27 owais-laptop kernel: [ 3130.499111] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB2
Sep 30 15:45:27 owais-laptop kernel: [ 3130.509143] scsi44 : usb-storage 6-1:1.3
Sep 30 15:45:28 owais-laptop kernel: [ 3131.517057] scsi 44:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 0
Sep 30 15:45:28 owais-laptop kernel: [ 3131.519980] scsi 44:0:0:1: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
Sep 30 15:45:28 owais-laptop usb_modeswitch: switched to 12d1:140b (HUA├┐WEI TECHNOLOGIES: HUAWEI Mobile)
Sep 30 15:45:28 owais-laptop kernel: [ 3131.548883] sr1: scsi-1 drive
Sep 30 15:45:28 owais-laptop kernel: [ 3131.549148] sr 44:0:0:0: Attached scsi generic sg2 type 5
Sep 30 15:45:28 owais-laptop kernel: [ 3131.550627] sd 44:0:0:1: Attached scsi generic sg3 type 0
Sep 30 15:45:28 owais-laptop kernel: [ 3131.591897] sd 44:0:0:1: [sdb] Attached SCSI removable disk
Sep 30 15:47:31 owais-laptop pppd[22151]: pppd 2.4.5 started by root, uid 0
Sep 30 15:47:31 owais-laptop pppd[22151]: Using interface ppp0
Sep 30 15:47:31 owais-laptop pppd[22151]: Connect: ppp0 <--> /dev/ttyUSB0
Sep 30 15:48:01 owais-laptop pppd[22151]: LCP: timeout sending Config-Requests
Sep 30 15:48:01 owais-laptop pppd[22151]: Connection terminated.
Sep 30 15:48:01 owais-laptop pppd[22151]: Receive serial link is not 8-bit clean:
Sep 30 15:48:01 owais-laptop pppd[22151]: Problem: all had bit 7 set to 0
Sep 30 15:48:01 owais-laptop pppd[22151]: Modem hangup
Sep 30 15:48:01 owais-laptop pppd[22151]: Exit.

Is this a network trouble or tool trouble?

0
2019-05-13 04:30:04
Source Share
Answers: 1

All right. Resembles it was a network trouble. absolutely nothing incorrect with the tool or the arrangement.

0
2019-05-13 18:11:38
Source