802.3 advertisement on FreeBSD and also Linux making use of crossover wires?

I have arrangement a NFS web server on FreeBSD 8.1, which will certainly be offering one Linux customer. Each box has a twin - port 1gig fiber card, and also each box is straight attached to the various other over this link. There is no button entailed.

I intend that my inquiry is, given that both FreeBSD and also Linux assistance 802.3 advertisement, is the adhering to properly to configure this, when not making use of a button? Or exists a far better means? Is this also sustained?

With this arrangement, I have the ability to ping in between the hosts, transfer files over NFS, etc

FreeBSD  em2 <-> eth2 Linux 
         em3 <-> eth3

I have actually set up em2 and also em3 for 802.3 advertisement (lacp):

lagg0: flags=8843 metric 0 mtu 1500
 options=9b
 ether 00:04:23:c2:c2:e0
 inet 192.168.0.1 netmask 0xfffffffc broadcast 192.168.0.3
 media: Ethernet autoselect
 status: active
 laggproto lacp
 laggport: em3 flags=1c
 laggport: em2 flags=1c
if_lagg_load="YES"
ifconfig_em2="UP"
ifconfig_em3="UP"
#ifconfig_lagg0="create"
cloned_interfaces="lagg0"
ifconfig_lagg0="laggproto lacp laggport em2 laggport em3 192.168.0.1 netmask 255.255.255.252"

And eth2 and also eth3 for 802.3 advertisement bonding:

[[email protected] ~]# ifconfig bond0
bond0     Link encap:Ethernet  HWaddr 00:04:23:C2:C4:DA  
          inet addr:192.168.0.2  Bcast:192.168.0.3  Mask:255.255.255.252
          inet6 addr: fe80::204:23ff:fec2:c4da/64 Scope:Link
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
          RX packets:140000208 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101560577 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3281219872 (3.0 GiB)  TX bytes:3609990240 (3.3 GiB)
[[email protected] network-scripts]# cat ifcfg-bond0 
DEVICE=bond0
IPADDR=192.168.0.2
NETWORK=192.168.0.0
NETMASK=255.255.255.252
USERCTL=no
BOOTPROTO=none
ONBOOT=yes
[[email protected] network-scripts]# cat ifcfg-eth2
DEVICE=eth2
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none
[[email protected] network-scripts]# cat ifcfg-eth3
DEVICE=eth3
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none
[[email protected] network-scripts]# tail -n2 /etc/modprobde.conf
alias bond0 bonding
options bond0 mode=802.3ad miimon=100

EDIT : I've located that, on the FreeBSD box, the MAC addresses of em2 and also em3 coincide, where - as on the Linux box, the MAC addresses of eth2 and also eth3 are various.

0
2019-05-13 05:47:29
Source Share
Answers: 0