Can not connect to Internet from Terminal and also various other programs (authentincation entailed)

I have a brand name - new Ubuntu 10.10 mounted in a VMWare 7.1 Workstation. I remain in a LAN and also we are attached to Internet via a proxy which calls for authentication.

I make use of 3 (3) internet browsers: The most recent variations of Opera, Chrome and also Firefox. Every one of them is set up to seek our proxy at the IP 192.168.3.1 (instance offered) and also the port 8081. Every one of them locates the proxy, requests for the username and also the password and also hereafter attaches appropriately to the Internet.

The very same point looks for the Synaptic Package Manager: Having the proper proxy information in the Settings - > Preferences - > Network it functions ok.

Nonetheless the Ubuntu Software Center falls short to install any kind of plan which I will certainly pick. The mistake (s) is/are Authentication failure.

Additionally in Terminal releasing a sudo apt-get install mypackage the APT can not connect to the required database to bring the information from there.

Additionally I state that I have actually set up in the Ubuntu is Main Menu in System - > Preferences - > Network Proxy Preferences the proper values for proxy (IP address, port and also the authentication little bits: username & password).

The intriguing point is that if I do the adhering to actions, it functions:

  1. Start the Synaptic.
  2. Start the Ubuntu Software Center.
  3. Pick something to install from Ubuntu Software Center. It will certainly toss a 'Waiting for Synaptic to close ...'
  4. Close the Synaptic.
  5. Install what you desire from the Ubuntu Software Center. (and also probably additionally from incurable - not examined)

What I'm missing out on? Just how can I set up various other programs (mostly the Terminal and also the Ubuntu Software Center) to do well attaching to internet?

UPDATE: Yes, I've pushed the Apply changes system-wide ... in the Ubuntu is Network Proxy is dialog.

0
2019-05-18 21:36:47
Source Share
Answers: 3

No, I do not assume you are missing out on anything, it is a bug which has actually currently been reported as Bug 545134 on launch pad.

0
2019-05-21 06:02:22
Source

I'm operating in a comparable setting, and also I've addressed the trouble as adheres to:
1) install and also set up CNTLM:
sudo apt-get install cntlm
sudo nano /etc/cntlm.conf
2) enter in cntlm.conf proxy setups & login qualifications for your network
3) factor your internet browser (s)' proxy setups to http://localhost:3128/
4) add these 3 lines to ~/. bashrc or to international/ etc/bash. bashrc
export http_proxy=http://localhost:3128/
export https_proxy=http://localhost:3128/
export ftp_proxy=http://localhost:3128/
5) logout and also login once more: every little thing needs to function!

Bye

0
2019-05-21 05:56:46
Source

To set a proxy from an incurable you can do the adhering to

export http_proxy='http://user:[email protected]:port/'

or for a safe and secure proxy

export https_proxy='http://user:[email protected]:port/'

Add the corresponding line to ~/.bashrc to make the adjustment irreversible (and also relogin).

Bear in mind that it would not function if there is any kind of unique personality in your username or password.

0
2019-05-21 04:54:20
Source