Problem with xmobar

I'm establishing an xmonad window manager and also I found adhering to trouble - when I attempt to set up xmobar and also run it it reveals:

xmobar: .xmobarrc: configuration file contains errors!
Usage: xmobar [OPTION...] [FILE]
Options:
  -h, -?        --help               This help
  -V            --version            Show version information
  -f font name  --font=font name     The font name
  -B bg color   --bgcolor=bg color   The background color. Default black
  -F fg color   --fgcolor=fg color   The foreground color. Default grey
  -o            --top                Place xmobar at the top of the screen
  -b            --bottom             Place xmobar at the bottom of the screen
  -a alignsep   --alignsep=alignsep  Separators for left, center and right text
                                     alignment. Default: '}{'
  -s char       --sepchar=char       The character used to separate commands in
                                     the output template. Default '%'
  -t template   --template=template  The output template
  -c commands   --commands=commands  The list of commands to be executed

Mail bug reports and suggestions to <[email protected]>

My arrangement documents

Config { font = "-*-Fixed-Bold-R-Normal-*-13-*-*-*-*-*-*-*"
       , bgColor = "black"
       , fgColor = "grey"
       , position = Top
       , commands = [ Run Weather "EGPF" ["-t","<station>: <tempC>C","-L","18","-H","25","--normal","green","--high","red","--low","lightblue"] 36000
                    , Run Cpu ["-L","3","-H","50","--normal","green","--high","red"] 10
                    , Run Memory ["-t","Mem: <usedratio>%"] 10
                    , Run Swap [] 10
                    , Run Date "%a %b %_d %l:%M" "date" 10
                    , Run StdinReader
                    ]
       , sepChar = "%"
       , alignSep = "}{"
       , template = "%StdinReader% }{ %cpu% | %memory% * %swap%    <fc=#ee9a00>%date%</fc> | %EGPF%"
       }

Configuration replicated from haskell wiki. My variation of xmobar is 0.9.2.

0
2019-05-18 22:32:44
Source Share
Answers: 2

This arrangement functioned :

Config { font = "-misc-fixed-*-*-*-*-13-*-*-*-*-*-*-*"
       , bgColor = "black"
       , fgColor = "grey"
       , position = TopW L 100
       , lowerOnStart = True
       , commands = [ Run Cpu ["-L","15","-H","50","--normal","green","--high","red"] 10
                    , Run Date "%a %b %_d %Y %H:%M:%S" "date" 10
                    , Run StdinReader
                    ]
       , sepChar = "%"
       , alignSep = "}{"
       , template = "%StdinReader% }{ %cpu% | %date%"
       }
0
2019-12-04 09:26:19
Source

When I attempt to run xmobar with your config I have the mistake

xmobar: customer mistake (createFontSet)

It need to be various, due to the fact that I'm making use of variation 0.11.1

To deal with that I need to transform the line with typeface readying to

font = "xft: Liberation Mono: pixelsize = 10"

0
2019-05-21 06:11:48
Source