How to stop gnome from vehicle - placing a partition?

I have a partition on my Hard Drive that I desire customers to be able to place, yet it should not be automated, so I've placed this in my/ etc/fstab:

     /dev/sda5       /media/data    vfat    defaults,user,noauto    0   0

It functions wonderful for command line. The partition is placed just when a person clearly places it.

Yet whenever a customer begins gnome, it automounts the partition, despite the fact that fstab claims it is not suposed to be placed instantly.

I recognize this is likely a gnome setup, yet I simply could not locate it in gconf - editor (it looks way too much like the Windows register editor for me).

Can any person aid me figure this out?

0
2019-05-18 23:00:23
Source Share
Answers: 1

There is a spot to get gnome to recognize the noauto flag:

http://patches.ubuntu.com/by-release/extracted/ubuntu/g/gnome-volume-manager/2.17.0-2ubuntu2/02_honour_automount_enabled_hint.patch

From the bordering string, it resembles it is been overlooking it for a number of variations currently:

http://ubuntuforums.org/showthread.php?t=989666

0
2019-05-21 07:29:25
Source