httpd.conf and also establishing a pen name

I am attempting to set up a pen name in my httpd.conf documents to make sure that I can consider my log documents using my internet browser. The following is the pen names that I am attempting to create.

Alias /logs "/<servername>/log"
<Directory /<servername>/log>
  Options Indexes FollowSymLinks
  AuthName "Application Logs"
  AuthType Basic
  AuthUserFile /<servername>/ihs/610/conf/.htpasswd
  <Limit GET POST>
     require valid-user
  </Limit>
</Directory>

This functions ALRIGHT on my programmer box yet out my manufacturing box. The differnce is that on my manufacturing box, my application is mounted with a context origin of /. When I key in my URL and also add the pen names (as an example mysite.com/logs), as opposed to seeing the log directory site, I am seeing my personalized 404 mistake web page.

I assume this is due to the fact that I am not making use of a context origin or simply / for my application and also all demands will certainly be postponed by the application.

Exists any kind of workaround?

0
2019-05-18 23:04:46
Source Share
Answers: 3

Presumably your "application" is some type of Django/PHP/Perl something - or - various other that does every one of the URL managing itself, right? Relying on just how that is set up, you might require to relocate this arrangement to previously in the config documents, or if your application is set up making use of RewriteRules, add an exemption to permit this prefix to travel through without causing your application.

0
2019-05-21 09:25:14
Source

If I recognize appropriately, you are making use of a different item of httpd.conf or a.htaccess to course URLs to your applicaton ... something similar to this:

RewriteRule ^(.*)$ /index.php?route=$1

You need to have the ability to either add a.htaccess documents right into your log directory site and also switch off the revising, or add

RewriteCond %{REQUEST_URI} !^/logs
RewriteRule ... as above...
0
2019-05-21 09:24:22
Source

Something similar to this needs to function:

you need to place, not some sort of It need to resemble "/ home/httpd/www/ logs/" or "/ var/log/apache/ log/".

And also it is far better to end up directory sites with "/". It might be necessary in some arrangements.

Alias /logs/ "/<path to your directory>/log/"
<Directory /<path to your directory>/log/>
  Options Indexes FollowSymLinks
  AuthName "Application Logs"
  AuthType Basic
  AuthUserFile /<path to your directory>/ihs/610/conf/.htpasswd
  <Limit GET POST>
     require valid-user
  </Limit>
</Directory>
0
2019-05-21 08:42:51
Source