Mac OS X Terminal [Use alternative as meta key ] overrides backslash in spanish keyboard

I currently uploaded this inquiry in stackoverflow:

https://stackoverflow.com/questions/4811282/mac-os-x-terminal-use-option-as-meta-key-overrides-backslash-in-spanish-keyboar

yet I was educated there that this is the appropriate area to ask it.

I examine "Use alternative as meta key" checkbox in Mac OS X Terminal, due to the fact that I such as to make use of emacs means of relocating in between words: M - f & M - b.

Yet if I do that, I can not get the backslash (Option+º ; i.e.: Option+key - at - the - left - of - 1 - in - spanish - keyboard). If I uncheck it, after that I can input the backslash, yet I do not have M - f & M - b.

Is there a means to get both? This is driving me nuts!

0
2019-05-19 00:08:44
Source Share
Answers: 1

And, as I currently addressed you on stackoverflow, the remedy is to place the adhering to line right into your ~/.bash_profile, which remaps the unicode personality "∫" (Unicode: E288AB, which is what is sent out to your terminal now in your wanted arrangement when you push Option+°) to the backslash personality:

bind '"\033\xE2\x88\xAB"':'"\\"'
0
2019-05-21 10:29:40
Source