How can I install Adobe AIR?

I am a hefty customer of particular applications that are improved AIR.

It shows up that AIR has actually stopped assistance for Linux. Also the older variations in the Adobe AIR Archives appear to sustain just 32 bit Linux circulations and also I get on 64 bit presently.

Exists also a mild opportunity that I could run AIR in these problems? If so, can you please inform me where can I get a thorough detailed installment for this?

160
2022-06-30 02:31:12
Source Share
Answers: 3

Alternately, you can install a prebuilt.deb

There is air 2.6 (last sustained Linux one) readily available here for both styles (Both make use of 32 little bit below yet at the very least it functions). Many thanks to prusswan for aiming it out.

See to it you have 32 little bit libs it'll need:

sudo apt-get install ia32-libs

I downloaded and install the AMD64 one (adobeair_2.6.0 .19170_amd64. deborah) and also mounted on my computer system (am64 with Precise Pangolin 12.04)

sudo dpkg -i adobeair_2.6.0.19170_amd64.deb

Then I mounted the application that required Adobe Air to begin with and also it functioned.

Update for Ubuntu 13:10+,

Trying this strategy, i get "Package ia32 - libs - gtk is not installed"

I sought out the package and also attempted mounting those dependences and also various other relevant plans I can consider directly:

sudo apt-get install gtk2-engines:i386 libart-2.0-2:i386 libcairo2:i386 libcanberra-gtk0:i386 libdatrie1:i386 libgail-common:i386 libgconf2-4:i386 libgtk2.0-0:i386 liblua5.1-0:i386 libpango1.0-0:i386 libpixman-1-0:i386 libqt4-network:i386 libqt4-test:i386 libqtcore4:i386 libthai0:i386 libbonobo2-0:i386 libglade2-0:i386 libgnomecanvas2-0:i386 libidl0:i386 liborbit2:i386 libwmf0.2-7:i386 gtk2-engines-murrine:i386

But that really did not benefit either the deborah or original binary.

19
2022-07-25 17:04:22
Source
  1. Download Latest Version Air 2.6.0 For Linux to your Desktop:

Maybe you'll get a mistake after the last command?

Sorry, a mistake has actually taken place. Adobe AIR can not be mounted. Install either Gnome Keyring or KDE KWallet prior to mounting Adobe AIR.

This can be fixed:

  • In an incurable (default faster way: Ctrl+Alt+T), type:

    locate libgnome-keyring.so
    
  • This is my outcome (your own could be various) :

    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0
    
  • As recommended listed below by @jmendeth, the most convenient means to inform the installer where to locate these documents is to make use of LD_LIBRARY_PATH:

    • For 32 - little bit Ubuntu (examined on 12.04) :

      LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu ./AdobeAIRInstaller.bin
      
    • For 64 - little bit Ubuntu, the command line would possibly be:

      LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu ./AdobeAIRInstaller.bin
      

If the LD_LIBRARY_PATH method does not function, you can attempt this:

  • Create a symbolic link to your area strings that you located with the previous commands:

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Use adhering to commands for 32 - little bit systems:

    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Then repeat action 4 & 6 (miss 5, as the approval to execute the documents hasn't transformed).

  • Remove symbolic web links after installment of Adobe AIR 2.6.0 :

    sudo rm /usr/lib/libgnome-keyring.so.0
    sudo rm /usr/lib/libgnome-keyring.so.0.2.0
    

Reference:

232
2022-07-12 15:04:33
Source

Step 1: Get some Air Next download the Adobe Air .bin file (direct link here).

Step 2: Installation

Open a terminal (applications > Accessories > Terminal) and navigate to your Downloads folder (or the folder in which you saved the .bin file).

* cd Download/

We need to let the .bin file have permissions to install so enter the following command carefully: -

* chmod +x AdobeAIRInstaller.bin

Now lets install it:

* ./AdobeAIRInstaller.bin

Installation should zip though and, if everything goes okay, a new menu entry will appear in ‘Applications > Accessories’ titled ‘Adobe Air Application Installer’.

6
2022-07-01 19:56:02
Source