Dual booting Debian and Windows 8?

My problem is a little weird (maybe to me only).

Specification: Lenovo, Ideapad Z510. i7 intel core. 1920x1080. ISO: GNOME Debian 7.2.0 amd64. Bootable Device: Universal USB Installer.

---Process begins---

After making the bootable USB, I, in Windows 8, go to Settings -> Change PC Settings -> Update and Recovery -> ... -> Change UEFI Settings.

In the UEFI settings, I directly make the boot method Legacy Boot with Legacy First enabled. I restart. As I expect, of course, the installation screen shows up. I hit Install, without DHCP network configured because my computer can only access a wireless network at the time. When dealing with the partitioning, I see that I have already had an ESP, so I only did two things: 1. Have a 4-GiB free space formatted to be the swap area; 2. Have a 100-GiB free space formatted to be the ex4 primary partition. Then I go on installing. The progress is fluid, and after finishing, I reboot it.

Hooray! I see both Debian and Windows 8 on the GRUB menu (I am still in Legacy Boot method).

Here come the problems:

I hit "Debian..." on the GRUB menu, and I see this: "GNOME 3 failed to load... Unfortunately GNOME 3 failed to start properly and started in the fallback mode. This most likely means your system (graphics hardware or driver) is not capable of delivering the full GNOME 3 experience... Learn more about GNOME 3". I looked up the Internet and I found something about 3D acceleration, but it doesn't apply. How do I know it doesn't? I boot the GNOME Debian live CD 64-bit in VMWare Player with 3D Acceleration turned on, but the message still pops up. So here is the first problem I have.

I hit "Windows 8" on the GRUB menu, and I see this: "Windows failed to start. A recent hardware or software change might have caused the issue...". Probably it's because I am using Legacy Boot.

--- Process stops ---

The only way to dual-boot successfully is to make Debian boot under UEFI boot method with Secure Boot turned off and Fast Boot (in Power Options in Control Panel in Windows 8) turned off. In short, what I need is that Debian will boot normally without any form of errors (like the GNOME 3 message above) with UEFI Boot turned on and Secure Boot disabled.

I first try to do this by getting in Debian. After opening a terminal with my mouse (Ctrl-Alt-T doesn't work and I haven't checked the keyboard shortcut yet.), I typed in "grub-install" but it complains "command not found"; thus I am not able to proceed. I checked the /boot directory but I didn't see the "efi" directory. I don't know why when there should be one since GRUB 2 can be for UEFI boot. By the way, during the installation I see the grub-install run without any warning or error so I am super confused right now.

I try to use EasyBCD but Debian won't boot, but saying something similar to "Windows 8 failed to start...".

I try different software for creating a bootable device including YUMI, Unetbootin, SARDU, but the problem is still not solved.

3
2022-07-25 20:39:10
Source Share
Answers: 0