Realtek drivers prevent detection of eth1 interface?

Here's the situation: I had a working network setup on my Debian box, with two Ethernet interfaces being reported by ifconfig - eth0, and eth1. eth0 is an onboard Realtek NIC, and eth1 is a D-Link PCI NIC. Sound, however, was not working on the system.

Following the advice on , I went to and downloaded the "LINUX driver for kernel 3.x and 2.6.x and 2.4.x". I unzipped it, and after installing the necessary build and Linux header packages, I ran r8168-8.037.00/autorun.sh as root. Upon review, I made a big mistake here. I clicked on "Realtek PCIe GBE Family Controller Series Drivers" rather than "HD Audio Codec Driver", so I installed their networking driver instead of their audio driver. Oops. In any case, I am now looking for a way to undo this mess.

No error messages seemed to be output, but sound was still not working, so I rebooted the machine. When it came up again, ifconfig -a now only shows me the eth0 interface and not eth1. Also, find /sys/devices/ -type d | grep eth only returns me eth0 devices, and no eth1 devices. Nor does dmesg | grep eth1 give any output. Somehow the new Realtek drivers have prevented eth1 from being detected! Sound still isn't working, by the way.

How is this happening and how can I fix it? I guess I'll have to live without sound but I want to get back my working eth0 and eth1 configuration. How can I get Linux detecting eth1 again?

It looks like it may have installed some stuff into /lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/realtek, if that helps. For example, the r8168.ko file is in both the src directory of the drivers I unzipped, and in that /lib... directory.

0
2022-07-25 20:39:14
Source Share
Answers: 0