sshfs will not use ~/.ssh/config (on Linux Mint 15)

Local:         Linux Mint 15 - Olivia
/proc/version: Linux version 3.8.0-19-generic ([email protected]) (gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1) )
ssh -V:        OpenSSH_6.1p1 Debian-4, OpenSSL 1.0.1c 10 May 2012
sshfs -V:      SSHFS version 2.4
               FUSE library version: 2.9.0
               fusermount version: 2.9.0
               using FUSE kernel interface version 7.18

Remote:        Ubuntu 12.04.3 LTS
/proc/version: Linux version 3.10.9-xxxx-std-ipv6-64 ([email protected]) (gcc version 4.7.2 (Debian 4.7.2-5) )
ssh -V:        OpenSSH_5.9p1 Debian-5ubuntu1.1, OpenSSL 1.0.1 14 Mar 2012

I'm attempting to set up a password - much less place of a remote web server making use of sshfs and also fuse. The remote web server is working on a non typical port and also I will certainly be making use of a ssh key set to confirm.

When effective I will certainly be duplicating this for 3 farther web servers each with various keys so I do require to be able to define which key maps to which remote web server.

I based my alterations off

  • The public key remains in remote: authorized_keys
  • I have actually included my neighborhood customer to the fuse team
  • I have actually modified my neighborhood ~/.ssh/config to have (per web server):

`

Host [server_ip]
  Port = [port]
  IdentityFile  = "~/.ssh/[private_key]"
  User = "[user]"

`

Whenever I attempt to place the remote web server in your area I get motivated for the remote customer is password (not my exclusive key is password). The remote customer has a lengthy arbitrarily created password that I would certainly such as to not need to conserve or bear in mind therefore keys is just how I intend to do this.

I can connect via ssh (incorporated with the ~/.ssh/config documents) making use of the command ssh [ip] so I recognize that the config documents can be read appropriately as I am requested for my key is passphrase not the remote customer's.

To also try to connect to the remote web server I need to by hand define the complete link information in the command: `sshfs [user] @ [ip]: [remote_path] [local_path] - p [port]

What I've attempted so far:

  • ssh - add/ path/to/key (effective enhancement)
  • Specifying PreferredAuthentication = publickey in ~/. ssh/config
  • sshfs - o IdentityFile =/ path/to/key [email protected]:// my/mnt/dir
  • sshfs [email protected]:// my/mnt/dir - o IdentityFile =/ path/to/key
  • temperature rename of key to default of id_rsa
  • sshfs - F ~/. ssh/config

Is there a remote or neighborhood arrangement documents that I'm forgeting? Some button or alternative that I require to include in the call to sshfs (attempted - F) to compel it to read and also utilize my ssh config?

Result of ssh -v -p [port] [user]@[remote_ip]

OpenSSH_6.1p1 Debian-4, OpenSSL 1.0.1c 10 May 2012
debug1: Reading configuration data /home/[me]/.ssh/config
debug1: /home/[me]/.ssh/config line 2: Applying options for [remote_ip]
debug1: /home/[me]/.ssh/config line 24: Applying options for *
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to [remote_ip] [[remote_ip]] port [port].
debug1: Connection established.
debug1: identity file /home/[me]/.ssh/[private_key] type 2
debug1: Checking blacklist file /usr/share/ssh/blacklist.DSA-1024
debug1: Checking blacklist file /etc/ssh/blacklist.DSA-1024
debug1: identity file /home/[me]/.ssh/[private_key]-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.9p1 Debian-5ubuntu1.1
debug1: match: OpenSSH_5.9p1 Debian-5ubuntu1.1 pat OpenSSH_5*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.1p1 Debian-4
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 [email protected]
debug1: kex: client->server aes128-ctr hmac-md5 [email protected]
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: [key]
debug1: checking without port identifier
debug1: Host '[remote_ip]' is known and matches the ECDSA host key.
debug1: Found key in /home/[me]/.ssh/known_hosts:7
debug1: found matching key w/out port
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering DSA public key: /home/[me]/.ssh/[private_key]
debug1: Server accepts key: pkalg ssh-dss blen 433
debug1: Enabling compression at level 6.
debug1: Authentication succeeded (publickey).
Authenticated to [remote_ip] ([[remote_ip]]:[port]).
debug1: channel 0: new [client-session]
debug1: Requesting [email protected]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_GB.UTF-8
debug1: Sending env LC_CTYPE = en_GB.UTF-8
Welcome to Ubuntu 12.04.3 LTS (GNU/Linux 3.10.9-xxxx-std-ipv6-64 x86_64)

Edit: ยข I located the trouble. I was attempting to place the remote area to/ mnt/new _ dir making use of sudo. If I place to an area within my neighborhood residence after that it functions, sshfs -p [port] [user]@[ip]:/ /home/[me]/tmp/mount

I have actually currently done a sudo chown root:fuse /mnt/new_dir and also sudo chmod 774 /mnt/new_dir and also I think that all is functioning as planned.

Exist any kind of protection concerns with this set up that I require to be knowledgeable about? (My very own customer and also origin are the only participants of of the fuse team.

13
2022-07-25 20:42:42
Source Share
Answers: 0